EIGRP Frame Relay Hub and Spoke

some text




EIGRP Frame Relay Hub and Spoke: Router Used As Frame Switch

Objective:
<> Review basic configuration of EIGRP on a serial interface.
<> Configure the bandwidth-percent command.
<> Configure EIGRP over Frame Relay hub and spoke.
<> Use EIGRP in non-broadcast mode.
<> Enable EIGRP manual summarization in topologies with discontiguous
   major networks.

Note: The interface numbers on your devices will
      probably differ from those in the topology diagram.

Scenatio:
You are responsible for configuring and testing the new network that
connects your company’s headquarters and Tincup1 and Tincup2 branches.
The three locations are connected over hub-and-spoke Frame Relay,
using the company headquarters as the hub.

To simulate the Frame Relay WAN connections, use a router with three
serial ports configured as a frame switch.


================================<()>================================

Step 1: Addressing
Using the addressing scheme in the diagram, apply IP addresses to the
loopback interfaces on HQ,Tincup1 and Tincup2.

hostname HQ
!
interface Loopback1
ip address 10.1.1.1 255.255.224.0
!
interface Loopback33
ip address 10.1.33.1 255.255.224.0
!
interface Loopback65
ip address 10.1.65.1 255.255.224.0
!
interface Loopback97
ip address 10.1.97.1 255.255.224.0
!
interface Loopback129
ip address 10.1.129.1 255.255.224.0
!
interface Loopback161
ip address 10.1.161.1 255.255.224.0
!
end


#####################


Tincup1
!
interface Loopback1
ip address 10.2.1.1 255.255.224.0
interface Loopback33
ip address 10.2.33.1 255.255.224.0
interface Loopback65
ip address 10.2.65.1 255.255.224.0
interface Loopback97
ip address 10.2.97.1 255.255.224.0
interface Loopback129
ip address 10.2.129.1 255.255.224.0
interface Loopback161
ip address 10.2.161.1 255.255.224.0
!
end


#####################


Tincup2
!
interface Loopback1
ip address 10.3.1.1 255.255.224.0
interface Loopback33
ip address 10.3.33.1 255.255.224.0
interface Loopback65
ip address 10.3.65.1 255.255.224.0
interface Loopback97
ip address 10.3.97.1 255.255.224.0
interface Loopback129
ip address 10.3.129.1 255.255.224.0
interface Loopback161
ip address 10.3.161.1 255.255.224.0
!
end


Step 2: Configuring the Frame Relay Switch
        use a fourth Cisco router with three serial interfaces as a Frame
        Relay switch.

hostname FRS
!
frame-relay switching
!
interface Serial 0/0
description FR to HQ
encapsulation frame-relay
clock rate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial 0/1 201
frame-relay route 103 interface Serial 0/2 301
no shutdown
exit
!
interface Serial 0/1
description FSR to Tincup1
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial 0/0 102
no shutdown
exit
!
interface Serial 0/2
description FSR to Tincup2
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial 0/0 103
no shutdown
exit
!
end

Step 3: Configuring the Frame Relay Endpoints
You will be configuring HQ to be the Frame Relay hub, with East and
West as the spokes.

HQ# 

interface serial 0/1
ip address 172.16.124.1 255.255.255.248
encapsulation frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
no shutdown
exit
!

Tincup1#

interface serial 0/1
ip address 172.16.124.2 255.255.255.248
encapsulation frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.3 201 broadcast
no shutdown
exit
!


Tincup2#

interface serial 0/2
ip address 172.16.124.3 255.255.255.248
no frame-relay inverse-arp
encapsulation frame-relay
frame-relay map ip 172.16.124.1 301 broadcast
frame-relay map ip 172.16.124.2 301 broadcast
clock rate 64000
no shutdown
exit
!


Note that you have not yet configured the bandwidth parameter on these
serial links. This will be done in Step 4.


Implement the local mappings as follows:
HQ#
frame-relay map ip 172.16.124.1 102

Tincup1# 
frame-relay map ip 172.16.124.2 201

Ticup2# 
frame-relay map ip 172.16.124.3 301


Step 4: Setting Interface-Level Bandwidth

HQ# 
conf t 
interface serial 0/1
bandwidth 128

Tincup1# 
conf t
interface serial 0/1
bandwidth 64

Tincup2# 
conf t 
interface serial 0/2
bandwidth 64


HQ’s serial interface divides its total EIGRP bandwidth into the fractional
amounts according to the number of neighbors out that interface.

Question:
How much bandwidth on Serial 0/1 on HQ is reserved for EIGRP traffic
to East?

You can control both the bandwidth parameter and the EIGRP bandwidth
percentage on a per-interface basis. On HQ, limit the bandwidth used by
EIGRP to 40 percent without changing the bandwidth parameter on the
interface. You can accomplish this with the interface-level command ip.

HQ(config-if)# ip bandwidth-percent eigrp 1 40


Step 5: Configuring EIGRP
Configure EIGRP AS 1 on HQ, East, and West. First use the global
configuration mode command router eigrp as_number to get the EIGRP
configuration prompt.


HQ# 
conf t
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
exit
!

Tincup1# 
conf t
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
exit
!

Tincup2# 
conf t
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
exit
!


Router 1 needs the no ip split-horizon eigrp as_number command on
its serial Frame Relay interface. This command disables split horizon for
an EIGRP autonomous system. If split horizon is enabled (the default),
route advertisements from East to HQ do not travel to West and vice
versa.

HQ# 
conf t
interface serial 0/1
no ip split-horizon eigrp 1
exit
!


Step 6: Using Non-broadcast EIGRP Mode


HQ# 
conf t
router eigrp 1
neighbor 172.16.124.2 serial 0/1
neighbor 172.16.124.3 serial 0/1
exit
!

Tincup1# 
conf t
router eigrp 1
neighbor 172.16.124.1 serial 0/1
exit
!

Tincup2# 
conf t
router eigrp 1
neighbor 172.16.124.1 serial 0/2
exit
!


======================Testing=========================

IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   172.16.124.3            Se0/1            135 00:01:35   53  1140  0  9
0   172.16.124.2            Se0/1            138 00:06:16   56  1140  0  9
HQ#

!

Tincup1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/1            158 00:05:49   61  2280  0  15
Tincup1#

!


Tincup2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/2            159 00:02:17   79  2280  0  15
Tincup2#

!

HQ#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/1
     10.0.0.0/19 is subnetted, 18 subnets
D       10.2.0.0 [90/20640000] via 172.16.124.2, 00:07:27, Serial0/1
D       10.3.0.0 [90/20640000] via 172.16.124.3, 00:02:45, Serial0/1
C       10.1.0.0 is directly connected, Loopback1
D       10.2.32.0 [90/20640000] via 172.16.124.2, 00:07:27, Serial0/1
D       10.3.32.0 [90/20640000] via 172.16.124.3, 00:02:45, Serial0/1
C       10.1.32.0 is directly connected, Loopback33
D       10.2.64.0 [90/20640000] via 172.16.124.2, 00:07:29, Serial0/1
D       10.3.64.0 [90/20640000] via 172.16.124.3, 00:02:48, Serial0/1
C       10.1.64.0 is directly connected, Loopback65
D       10.2.96.0 [90/20640000] via 172.16.124.2, 00:07:29, Serial0/1
D       10.3.96.0 [90/20640000] via 172.16.124.3, 00:02:50, Serial0/1
C       10.1.96.0 is directly connected, Loopback97
D       10.2.128.0 [90/20640000] via 172.16.124.2, 00:07:31, Serial0/1
D       10.3.128.0 [90/20640000] via 172.16.124.3, 00:02:50, Serial0/1
C       10.1.128.0 is directly connected, Loopback129
D       10.2.160.0 [90/20640000] via 172.16.124.2, 00:07:31, Serial0/1
D       10.3.160.0 [90/20640000] via 172.16.124.3, 00:02:50, Serial0/1
C       10.1.160.0 is directly connected, Loopback161
HQ#

!

Tincup1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/1
     10.0.0.0/19 is subnetted, 18 subnets
C       10.2.0.0 is directly connected, Loopback1
D       10.3.0.0 [90/41152000] via 172.16.124.1, 00:03:23, Serial0/1
D       10.1.0.0 [90/40640000] via 172.16.124.1, 00:07:55, Serial0/1
C       10.2.32.0 is directly connected, Loopback33
D       10.3.32.0 [90/41152000] via 172.16.124.1, 00:03:23, Serial0/1
D       10.1.32.0 [90/40640000] via 172.16.124.1, 00:07:55, Serial0/1
C       10.2.64.0 is directly connected, Loopback65
D       10.3.64.0 [90/41152000] via 172.16.124.1, 00:03:25, Serial0/1
D       10.1.64.0 [90/40640000] via 172.16.124.1, 00:07:58, Serial0/1
C       10.2.96.0 is directly connected, Loopback97
D       10.3.96.0 [90/41152000] via 172.16.124.1, 00:03:27, Serial0/1
D       10.1.96.0 [90/40640000] via 172.16.124.1, 00:07:59, Serial0/1
C       10.2.128.0 is directly connected, Loopback129
D       10.3.128.0 [90/41152000] via 172.16.124.1, 00:03:27, Serial0/1
D       10.1.128.0 [90/40640000] via 172.16.124.1, 00:07:59, Serial0/1
C       10.2.160.0 is directly connected, Loopback161
D       10.3.160.0 [90/41152000] via 172.16.124.1, 00:03:27, Serial0/1
D       10.1.160.0 [90/40640000] via 172.16.124.1, 00:07:59, Serial0/1
Tincup1#

!

Tincup2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/2
     10.0.0.0/19 is subnetted, 18 subnets
D       10.2.0.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial0/2
C       10.3.0.0 is directly connected, Loopback1
D       10.1.0.0 [90/40640000] via 172.16.124.1, 00:03:51, Serial0/2
D       10.2.32.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial0/2
C       10.3.32.0 is directly connected, Loopback33
D       10.1.32.0 [90/40640000] via 172.16.124.1, 00:03:51, Serial0/2
D       10.2.64.0 [90/41152000] via 172.16.124.1, 00:03:53, Serial0/2
C       10.3.64.0 is directly connected, Loopback65
D       10.1.64.0 [90/40640000] via 172.16.124.1, 00:03:53, Serial0/2
D       10.2.96.0 [90/41152000] via 172.16.124.1, 00:03:53, Serial0/2
C       10.3.96.0 is directly connected, Loopback97
D       10.1.96.0 [90/40640000] via 172.16.124.1, 00:03:53, Serial0/2
D       10.2.128.0 [90/41152000] via 172.16.124.1, 00:03:53, Serial0/2
C       10.3.128.0 is directly connected, Loopback129
D       10.1.128.0 [90/40640000] via 172.16.124.1, 00:03:53, Serial0/2
D       10.2.160.0 [90/41152000] via 172.16.124.1, 00:03:53, Serial0/2
C       10.3.160.0 is directly connected, Loopback161
D       10.1.160.0 [90/40640000] via 172.16.124.1, 00:03:53, Serial0/2
Tincup2#

!

HQ#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.161.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 20640000
        via 172.16.124.2 (20640000/128256), Serial0/1
P 10.3.0.0/19, 1 successors, FD is 20640000
        via 172.16.124.3 (20640000/128256), Serial0/1
P 10.1.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.2.32.0/19, 1 successors, FD is 20640000
        via 172.16.124.2 (20640000/128256), Serial0/1
P 10.3.32.0/19, 1 successors, FD is 20640000
        via 172.16.124.3 (20640000/128256), Serial0/1
P 10.1.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.2.64.0/19, 1 successors, FD is 20640000
        via 172.16.124.2 (20640000/128256), Serial0/1
P 10.3.64.0/19, 1 successors, FD is 20640000
        via 172.16.124.3 (20640000/128256), Serial0/1
P 10.1.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.96.0/19, 1 successors, FD is 20640000
        via 172.16.124.2 (20640000/128256), Serial0/1
P 10.3.96.0/19, 1 successors, FD is 20640000
        via 172.16.124.3 (20640000/128256), Serial0/1
P 10.1.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.2.128.0/19, 1 successors, FD is 20640000
        via 172.16.124.2 (20640000/128256), Serial0/1
P 10.3.128.0/19, 1 successors, FD is 20640000
        via 172.16.124.3 (20640000/128256), Serial0/1
P 10.1.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129
P 10.2.160.0/19, 1 successors, FD is 20640000
        via 172.16.124.2 (20640000/128256), Serial0/1
P 10.3.160.0/19, 1 successors, FD is 20640000
        via 172.16.124.3 (20640000/128256), Serial0/1
P 10.1.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 172.16.124.0/29, 1 successors, FD is 20512000
        via Connected, Serial0/1
HQ#

!

Tincup1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.2.161.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.3.0.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/1
P 10.2.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.3.32.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/1
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/1
P 10.2.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.3.64.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/1
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.3.96.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/1
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/1
P 10.2.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129
P 10.3.128.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/1
P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/1
P 10.2.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.3.160.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/1
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/1
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/1
        via 172.16.124.1 (41024000/20512000), Serial0/1
Tincup1#

!

Tincup2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.3.161.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/2
P 10.3.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/2
P 10.2.32.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/2
P 10.3.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/2
P 10.2.64.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/2
P 10.3.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/2

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.96.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/2
P 10.3.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/2
P 10.2.128.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/2
P 10.3.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129
P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/2
P 10.2.160.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/2
P 10.3.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/2
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/2
        via 172.16.124.1 (41024000/20512000), Serial0/2
Tincup2#