EIGRP Configuration, Bandwidth and Adjacencies




some text



Objectives:
<> Configure EIGRP on an interface
<> Configure the bandwidth command to limit EIGRP bandwidth
<> Verify EIGRP adjacencies
<> Utilize debugging commands for troubleshooting EIGRP


Step 1: Addressing
Using the addressing scheme in the diagram,apply IP addresses to the Fast
Ethernet interfaces on R1, R2, and R3.Then add Loopback1 on R1,
Loopback2 on R2, and Loopback3 on R3

R1#configure terminal
R1(config)# interface Loopback1
R1(config-if)# description Engineering Department
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# exit
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 10.1.100.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)


###


R2#configure terminal
R2(config)# interface Loopback2
R2(config-if)# description Marketing Department
R2(config-if)# ip address 10.1.2.1 255.255.255.0
R2(config-if)# exit
!
R2(config)# interface FastEthernet0/0
R2(config-if)# ip address 10.1.100.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
!

###


R3#configure terminal
R3(config)# interface Loopback3
R3(config-if)# description Accounting Department
R3(config-if)# ip address 10.1.3.1 255.255.255.0
R3(config-if)# exit
!
R3(config)# interface FastEthernet0/0
R3(config-if)# ip address 10.1.100.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
!

Leave the switch in its default configuration. By default, all switch ports
are in VLAN1.

For now, also leave the serial interfaces in their default configuration. You will
configure the serial link between R1 and R2 in Step 4.



R1#show ip interface brief Interface IP-Address OK? Method Status Protocol FastEthernet0/0 10.1.100.1 YES manual up up Serial0/0 unassigned YES unset administratively down down FastEthernet0/1 unassigned YES unset administratively down down Serial0/1 unassigned YES unset administratively down down Serial0/2 unassigned YES unset administratively down down Serial0/3 unassigned YES unset administratively down down FastEthernet1/0 unassigned YES unset administratively down down Loopback1 10.1.1.1 YES manual up up R1#
Step 2: Configuring EIGRP Across VLAN1 After you have implemented your addressing scheme, create an EIGRP autonomous system (AS) on R1. R1(config)# router eigrp 1 R1(config-router)# network 10.0.0.0
R1#debug eigrp packets EIGRP Packets debugging is on (UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY) R1# *Mar 1 00:20:21.031: EIGRP: Sending HELLO on Loopback1 *Mar 1 00:20:21.031: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 *Mar 1 00:20:21.035: EIGRP: Received HELLO on Loopback1 nbr 10.1.1.1 *Mar 1 00:20:21.035: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 *Mar 1 00:20:21.039: EIGRP: Packet from ourselves ignored R1#
- These Hello packets are unanswered by the other routers, because EIGRP is not yet running on R2 or R3. R1 ignores the Hello packets from itself on Loopback1. Use the undebug all (u all) command to stop the debug output. - Which interfaces are involved in EIGRPís routing process on this router? Use show ip eigrp interfaces to show which interfaces are participating in EIGRP.
R1#show ip eigrp interfaces IP-EIGRP interfaces for process 1 Xmit Queue Mean Pacing Time Multicast Pending Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes Fa0/0 0 0/0 0 0/1 0 0 Lo1 0 0/0 0 0/1 0 0 R1#
- Now, in global configuration mode on R2, issue the following command to create EIGRP AS 1 R2#conf t Enter configuration commands, one per line. End with CNTL/Z. R2(config)#router eigrp 1 R2(config-router)#network 10.0.0.0 R2(config-router)# - Configure EIGRP on R3 using the same commands. R3#conf t Enter configuration commands, one per line. End with CNTL/Z. R3(config)#router eigrp 1 R3(config-router)#network 10.0.0.0 R3(config-router)# Step 3: Verifying the EIGRP Configuration
R1#show ip eigrp neighbors IP-EIGRP neighbors for process 1 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 1 10.1.100.3 Fa0/0 11 00:01:04 122 732 0 7 0 10.1.100.2 Fa0/0 12 00:02:29 100 600 0 6 R1# ! R2#show ip eigrp neighbors IP-EIGRP neighbors for process 1 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 1 10.1.100.3 Fa0/0 12 00:01:18 125 750 0 7 0 10.1.100.1 Fa0/0 11 00:02:44 127 762 0 6 R2# ! R3#show ip eigrp neighbors IP-EIGRP neighbors for process 1 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 1 10.1.100.1 Fa0/0 14 00:01:36 117 702 0 7 0 10.1.100.2 Fa0/0 12 00:01:36 859 5000 0 7 R3#
- Now check whether the EIGRP routes are being exchanged between the routers
R1#show ip eigrp topology IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1) Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 10.1.3.0/24, 1 successors, FD is 409600 via 10.1.100.3 (409600/128256), FastEthernet0/0 P 10.1.2.0/24, 1 successors, FD is 409600 via 10.1.100.2 (409600/128256), FastEthernet0/0 P 10.1.1.0/24, 1 successors, FD is 128256 via Connected, Loopback1 P 10.1.100.0/24, 1 successors, FD is 281600 via Connected, FastEthernet0/0 R1#
- You should see all the networks currently advertised by EIGRP on every router. For now, verify that each of the loopback networks exist in the EIGRP topology table. Because EIGRP is the only routing protocol running and currently has routes to these networks.
R1#show ip route eigrp 10.0.0.0/24 is subnetted, 4 subnets D 10.1.3.0 [90/409600] via 10.1.100.3, 01:24:12, FastEthernet0/0 D 10.1.2.0 [90/409600] via 10.1.100.2, 01:25:37, FastEthernet0/0 R1#
Step 4: Configuring EIGRP on the Serial Interfaces Your serial interfaces are still in their default configuration state. Configure the interface according to the diagram, and set the clock rate to 64 kbps. R1(config)# interface serial 0/0 R1(config-if)# ip address 10.1.200.1 255.255.255.0 R1(config-if)# clock rate 64000 R1(config-if)# no shut ! R2(config)# interface serial 0/0 R2(config-if)# ip address 10.1.200.2 255.255.255.0 R2(config-if)# no shut Notice that even though you have clocked the interface at 64 kbps, issuing show interface serial 0/0 reveals that the interface still is a full T1 bandwidth of 1544 kbps.
R1#show interfaces serial 0/0 | i BW MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, R1#
By default, EIGRP uses up to 50 percent of the bandwidth that your interface reports to Cisco IOS software. Suppose there was a significant routing instability in some other part of our EIGRP AS. If EIGRP were to use 50 percent of 1544 kbps for its own routing information traffic, EIGRP traffic would fully saturate our measly 64 kbps serial link. - Apply the bandwidth 64 command to R1 and R2 serial interfaces as follows. R1: ! interface Serial 0/0 bandwidth 64 ! R2: ! interface Serial 0/0 bandwidth 64 ! Verify that your bandwidth configuration is reflected in the show interface serial 0/0 output
R1#show interfaces serial 0/0 | i BW MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, R1# ! R2#show interfaces serial 0/0 | i BW MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, R2#
Now, issue the show ip eigrp neighbors command, which displays the following neighbor relationship between R1 and R2
R1#show ip eigrp neighbors IP-EIGRP neighbors for process 1 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 2 10.1.200.2 Se0/0 14 00:15:16 79 2280 0 17 1 10.1.100.3 Fa0/0 12 01:49:20 78 468 0 15 0 10.1.100.2 Fa0/0 13 01:50:46 77 462 0 18 R1#
Step 5: Configuring Network Statement Wildcard Masks On R3 create loopback interface 11 IP address 192.168.100.1/30 and Loopback 15 IP address 192.168.100.5/30 R3(config)# interface Loopback11 R3(config-if)# ip address 192.168.100.1 255.255.255.252 R3(config-if)# exit R3(config)# interface Loopback15 R3(config-if)# ip address 192.168.100.5 255.255.255.252 R3(config-if)# exit How can you add the 192.168.100.0/30 network to EIGRP without involving the 192.168.100.4/30 network as well? In Step 2, we looked at how network statements select networks for routing using major network boundaries. EIGRP also provides a way to select networks using wildcard masks. In a wildcard mask, bits that may vary are denoted by 1s in the binary bit values. If we wanted to route both Loopback11 and Loopback15 with EIGRP, we could use a wildcard mask that includes both of their network addresses, such as network 192.168.100.0 0.0.0.7 or network 192.168.100.0 0.0.0.255. However, in this scenario, we only want to select Loopback11ís IP network. R3(config)#router eigrp 1 R3(config-router)#network 192.168.100.0 0.0.0.3 R3(config-router)# Did this solution work?
R3#show ip eigrp interfaces IP-EIGRP interfaces for process 1 Xmit Queue Mean Pacing Time Multicast Pending Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes Fa0/0 2 0/0 232 0/2 1020 0 Lo3 0 0/0 0 0/1 0 0 Lo11 0 0/0 0 0/1 0 0 R3#
Which of these two IP networks can you see in the routing table on R1 after EIGRP converges with the new network?
R1#show ip route eigrp 10.0.0.0/24 is subnetted, 5 subnets D 10.1.3.0 [90/409600] via 10.1.100.3, 00:17:12, FastEthernet0/0 D 10.1.2.0 [90/409600] via 10.1.100.2, 00:17:12, FastEthernet0/0 D 192.168.100.0/24 [90/409600] via 10.1.100.3, 00:03:32, FastEthernet0/0 R1#
R2#show ip route eigrp 10.0.0.0/24 is subnetted, 5 subnets D 10.1.3.0 [90/409600] via 10.1.100.3, 00:19:00, FastEthernet0/0 D 10.1.1.0 [90/409600] via 10.1.100.1, 00:19:00, FastEthernet0/0 D 192.168.100.0/24 [90/409600] via 10.1.100.3, 00:05:38, FastEthernet0/0 R2# ! R3#show ip route eigrp 10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks D 10.1.2.0/24 [90/409600] via 10.1.100.2, 02:06:55, FastEthernet0/0 D 10.1.1.0/24 [90/409600] via 10.1.100.1, 02:06:55, FastEthernet0/0 D 10.0.0.0/8 is a summary, 00:06:39, Null0 D 10.1.200.0/24 [90/40537600] via 10.1.100.2, 00:20:07, FastEthernet0/0 [90/40537600] via 10.1.100.1, 00:20:07, FastEthernet0/0 192.168.100.0/24 is variably subnetted, 3 subnets, 2 masks D 192.168.100.0/24 is a summary, 00:06:39, Null0 R3# ! R3#traceroute 10.1.1.1 Type escape sequence to abort. Tracing the route to 10.1.1.1 1 10.1.100.1 912 msec 24 msec 24 msec R3#
On R1, shut down the FastEthernet0/0 interface: R1(config)# interface FastEthernet0/0 R1(config-if# shutdown R1(config-if)#
R3#traceroute 10.1.1.1 Type escape sequence to abort. Tracing the route to 10.1.1.1 1 10.1.100.2 88 msec 28 msec 20 msec 2 10.1.200.1 40 msec 32 msec 20 msec R3#
R1(config-if)#no shutdown R1(config-if)#