EIGRP Authentication and Timers


some text



Objectives
<> Review basic configuration of EIGRP
<> Configure and verify EIGRP authentication parameters
<> Configure EIGRP hello interval and hold time
<> Verify the hello


====================================<()>=====================================



R1#

hostname R1
!
key chain EIGRP-KEYS
key 1
key-string cisco
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
exit

!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
no shutdown
exit

!
interface Serial 0/0
bandwidth 64
ip address 172.16.12.1 255.255.255.248
ip hello-interval eigrp 1 2
ip hold-time eigrp 1 8
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
clock rate 64000
no shutdown
exit
!
interface Serial 0/1
bandwidth 64
ip address 172.16.13.1 255.255.255.248
ip hello-interval eigrp 1 2
ip hold-time eigrp 1 8
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
no shutdown
exit
!
router eigrp 1
network 10.0.0.0
network 172.16.0.0
network 192.168.1.0
no auto-summary
!
end

!


############


hostname R2
!
key chain EIGRP-KEYS
key 1
key-string cisco
!
interface Loopback2
ip address 192.168.2.2 255.255.255.0
exit

!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
no shutdown
exit

!
interface Serial 0/0
bandwidth 64
ip address 172.16.12.2 255.255.255.248
ip hello-interval eigrp 1 2
ip hold-time eigrp 1 8
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
no shutdown
exit

!
interface Serial 0/1
bandwidth 64
ip address 172.16.23.2 255.255.255.248
ip hello-interval eigrp 1 2
ip hold-time eigrp 1 8
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
clock rate 64000
no shutdown
exit

!
router eigrp 1
network 10.0.0.0
network 172.16.0.0
network 192.168.2.0
no auto-summary
!
end

###############

!
hostname R3
!
key chain EIGRP-KEYS
key 1
key-string cisco
exit
exit
!

interface Loopback3
ip address 192.168.3.3 255.255.255.0
exit
!

interface FastEthernet0/0
ip address 10.1.1.3 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
no shutdown
exit
!

interface Serial 0/0
bandwidth 64
ip address 172.16.13.3 255.255.255.248
ip hello-interval eigrp 1 2
ip hold-time eigrp 1 8
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
clock rate 64000
no shutdown
exit
!

interface Serial 0/1
bandwidth 64
ip address 172.16.23.3 255.255.255.248
ip hello-interval eigrp 1 2
ip hold-time eigrp 1 8
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
no shutdown
exit
!

router eigrp 1
network 10.0.0.0
network 172.16.0.0
network 192.168.3.0
no auto-summary
!
end





=====================================Testing===================================

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
3   172.16.13.3             Se0/1              6 00:05:37   95  2280  0  29
2   10.1.1.3                Fa0/0             12 00:05:37   81   486  0  30
1   172.16.12.2             Se0/0              7 00:07:45  101  2280  0  49
0   10.1.1.2                Fa0/0             13 00:07:53  104   624  0  48
R1#



R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
3   172.16.23.3             Se0/1              6 00:05:46   53  2280  0  28
2   10.1.1.3                Fa0/0              9 00:05:53  215  1290  0  30
1   172.16.12.1             Se0/0              7 00:08:01   62  2280  0  55
0   10.1.1.1                Fa0/0             14 00:08:17  125   750  0  54
R2#



R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
3   172.16.23.2             Se0/1              6 00:06:07   97  2280  0  51
2   172.16.13.1             Se0/0              7 00:06:15   83  2280  0  56
1   10.1.1.1                Fa0/0             13 00:06:15  124   744  0  54
0   10.1.1.2                Fa0/0             14 00:06:15   97   582  0  48
R3#



R1#show key chain
Key-chain EIGRP-KEYS:
    key 1 -- text "cisco"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]
R1#



R1#show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              2        0/0        88       0/2          340           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/14  Un/reliable ucasts: 27/17
  Mcast exceptions: 6  CR packets: 6  ACKs suppressed: 1
  Retransmissions sent: 2  Out-of-sequence rcvd: 2
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use multicast
Se0/0              1        0/0        74      10/380        676           0
  Hello interval is 2 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 18/29
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 8
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
Se0/1              1        0/0       611      10/380       3360           0
  Hello interval is 2 sec
  Next xmit serial 

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 10/16
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 5
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
Lo1                0        0/0         0       0/1            0           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast
R1#



R2#show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              2        0/0       167       0/2          680           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/16  Un/reliable ucasts: 29/16
  Mcast exceptions: 6  CR packets: 6  ACKs suppressed: 1
  Retransmissions sent: 2  Out-of-sequence rcvd: 1
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use multicast
Se0/0              1        0/0        59      10/380        616           0
  Hello interval is 2 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 20/27
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 6
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
Se0/1              1        0/0        54      10/380        592           0
  Hello interval is 2 sec
  Next xmit serial 

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 5/7
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 1
  Retransmissions sent: 1  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
Lo2                0        0/0         0       0/1            0           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast
R2#



R3#show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              2        0/0       104       0/2          440           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/8  Un/reliable ucasts: 23/12
  Mcast exceptions: 3  CR packets: 2  ACKs suppressed: 0
  Retransmissions sent: 2  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use multicast
Se0/0              1        0/0        71      10/380        672           0
  Hello interval is 2 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 10/15
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 4
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
Se0/1              1        0/0        93      10/380        768           0
  Hello interval is 2 sec
  Next xmit serial 

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 4/8
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 1
  Retransmissions sent: 2  Out-of-sequence rcvd: 1
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
Lo3                0        0/0         0       0/1            0           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast
R3#



R1#show ip eigrp interfaces detail serial 0/0
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        74      10/380        676           0
  Hello interval is 2 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 18/29
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 8
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
R1#



R2#show ip eigrp interfaces detail serial 0/0
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        59      10/380        616           0
  Hello interval is 2 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 20/27
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 6
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP-KEYS"
  Use unicast
R2#