IOS DHCP Server



some text




Learning Objectives

 Configure and verify the operation of the Cisco IOS DHCP server
 Configure an IP Helper address
 Review the EIGRP configuration


Final Configurations

R1# show run
!
hostname R1
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
ip helper-address 172.16.2.1
!
interface Serial0/0/0
bandwidth 64
ip address 172.16.12.1 255.255.255.0
clock rate 64000
no shutdown
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
ip forward-protocol udp 50000

ip forward-protocol udp 3306
!

====================== end =======================

<()> Configure a DHCP Pool on Router 2

R2# show run
!
hostname R2
!
ip dhcp excluded-address 172.16.23.1 172.16.23.100
!
ip dhcp pool VLAN1-POOL
network 172.16.23.0 255.255.255.0
default-router 172.16.23.2
domain-name Tinnincup.com
lease 1 5 36
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.23.2 255.255.255.0
no shutdown
!
interface Serial0/0/0
bandwidth 64
ip address 172.16.12.2 255.255.255.0
no shutdown
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
end
R3# show run
!

====================== end =======================

R3# show run
!
hostname R3
!
interface FastEthernet0/0
ip address dhcp
no shutdown
!
end
====================== end =======================

Testing:



R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.12.2             Se0/0             14 00:04:01  150  2280  0  5
R1#

!


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 4 subnets
D       172.16.23.0 [90/40537600] via 172.16.12.2, 00:06:55, Serial0/0
C       172.16.12.0 is directly connected, Serial0/0
C       172.16.1.0 is directly connected, Loopback0
D       172.16.2.0 [90/40640000] via 172.16.12.2, 00:07:00, Serial0/0
R1#


!

R1#ping 172.16.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/68 ms
R1#

!

R1#traceroute 172.16.2.1

Type escape sequence to abort.
Tracing the route to 172.16.2.1

  1 172.16.12.2 68 msec 4 msec 4 msec
R1#


<^>

R2#show ip eigrp neighbors top
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.12.1             Se0/0             14 00:25:38   85  2280  0  3
R2#

!

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.16.2.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.23.0/24, 1 successors, FD is 281600
        via Connected, FastEthernet0/0
P 172.16.12.0/24, 1 successors, FD is 40512000
        via Connected, Serial0/0
P 172.16.1.0/24, 1 successors, FD is 40640000
        via 172.16.12.1 (40640000/128256), Serial0/0
P 172.16.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback2
R2#

!


R2#ping 172.16.1.1 source 172.16.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/34/68 ms
R2#

!

R2#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
172.16.23.101       0063.6973.636f.2d63.    Mar 02 2002 05:36 AM    Automatic
                    3030.332e.3237.3934.
                    2e30.3030.302d.4661.
                    302f.30
R2#

!

R2#show ip dhcp pool

Pool VLAN800-POOL :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 254
 Leased addresses               : 1
 Pending event                  : none
 1 subnet is currently in the pool :
 Current index        IP address range                    Leased addresses
 172.16.23.102        172.16.23.1      - 172.16.23.254     1
R2#
R2#



<^>

R3#show ip interface fastEthernet 0/0 | i DHCP|addre
  Internet address is 172.16.23.101/24
  Broadcast address is 255.255.255.255
  Address determined by DHCP
  Helper address is not set
  Network address translation is disabled
R3#