Basic EIGRP with Summarization




some text




EIGRP Summarization and Default Network Advertisement


Objectives:
<> Review basic EIGRP configuration
<> Configure and verify EIGRP auto-summarization
<> Configure and verify EIGRP manual summarization
<> Configure ip default-network advertisement with EIGRP




===============================<()>=================================


Step 1: Initial Configuration
Paste the following configurations below into each of your routers to 
begin the LAB.


R1# show run
!

hostname R1
!
interface Loopback0
ip address 172.31.1.1 255.255.255.252
!
interface Serial0/0
bandwidth 64
ip address 192.168.100.1 255.255.255.248
clock rate 64000
no shutdown
!
router eigrp 100
network 172.31.0.0
network 192.168.10.0
no auto-summary
!
end


################


R2# show run
!
hostname R2
!
interface Loopback1
ip address 192.168.200.1 255.255.255.252
!
interface Loopback5
ip address 192.168.200.5 255.255.255.252
!
interface Loopback9
ip address 192.168.200.9 255.255.255.252
!
interface Loopback13
ip address 192.168.200.13 255.255.255.252
!
interface Loopback17
ip address 192.168.200.17 255.255.255.252
!
interface Loopback21
ip address 192.168.200.21 255.255.255.252
!
interface Loopback25
ip address 192.168.200.25 255.255.255.252
!
interface Serial 0/0
bandwidth 64
ip address 192.168.100.2 255.255.255.248
no shutdown
exit
!
interface Serial 0/1
bandwidth 64
ip address 10.1.1.2 255.255.255.248
clockrate 64000
no shutdown
exit
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
network 192.168.200.0
no auto-summary
!
end


###########


R3# show run
!
hostname R3
!
interface Loopback1
ip address 192.168.1.1 255.255.254.0
!
interface Loopback5
ip address 192.168.5.5 255.255.254.0
!
interface Loopback9
ip address 192.168.9.9 255.255.254.0
!
interface Loopback13
ip address 192.168.13.13 255.255.254.0
!
interface Loopback17
ip address 192.168.17.17 255.255.254.0
!
interface Loopback21
ip address 192.168.21.21 255.255.254.0
!
interface Loopback25
ip address 192.168.25.25 255.255.254.0
!
interface Loopback100
ip address 10.1.3.1 255.255.255.252
!
interface Loopback172
ip address 172.16.1.1 255.255.255.252
!
interface Serial 0/1
bandwidth 64
ip address 10.5.5.3 255.255.255.248
no shutdown
exit
!
router eigrp 100
network 10.0.0.0
network 172.16.0.0
network 192.168.0.0 0.0.31.255
no auto-summary
!
end



R1#show ip eigrp neighbors IP-EIGRP neighbors for process 100 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 0 192.168.100.2 Se0/0 10 00:01:00 384 2304 0 9 R1# ! R2#show ip eigrp neighbors IP-EIGRP neighbors for process 100 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 1 192.168.100.1 Se0/0 11 00:01:07 121 2280 0 6 0 10.1.1.3 Se0/1 11 00:01:07 56 2280 0 3 R2# ! R3#show ip eigrp neighbors IP-EIGRP neighbors for process 100 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 0 10.1.1.2 Se0/1 14 00:01:15 1217 5000 0 11 R3#
- Ping all the IP addresses to ensure full connectivity. Step 2: Summarization Analysis For the following networks, which router should you summarize to minimize the size of the routing table for all the involved routers? What summary should you use?
  • 10.0.0.0/8 –
  • 172.16.0.0/16 –
  • 172.31.0.0/16 –
  • 192.168.100.0/24 –
  • 192.168.200.0/24 –
  • 192.168.0.0/23 through 192.168.24.0/23 Since all routes involved in this lab, including later summary routes, will be installed in the routing table by EIGRP, observe the routing table on each router with the show ip route eigrp command.
    R1#show ip route eigrp 172.16.0.0/30 is subnetted, 1 subnets D 172.16.1.0 [90/41152000] via 192.168.100.2, 00:00:17, Serial0/0 192.168.200.0/30 is subnetted, 7 subnets D 192.168.200.0 [90/40640000] via 192.168.100.2, 00:00:47, Serial0/0 D 192.168.200.4 [90/40640000] via 192.168.100.2, 00:00:47, Serial0/0 D 192.168.200.8 [90/40640000] via 192.168.100.2, 00:00:47, Serial0/0 D 192.168.200.12 [90/40640000] via 192.168.100.2, 00:00:47, Serial0/0 D 192.168.200.16 [90/40640000] via 192.168.100.2, 00:00:47, Serial0/0 D 192.168.200.20 [90/40640000] via 192.168.100.2, 00:00:47, Serial0/0 D 192.168.200.24 [90/40640000] via 192.168.100.2, 00:00:47, Serial0/0 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks D 10.1.3.0/30 [90/41152000] via 192.168.100.2, 00:00:47, Serial0/0 D 10.1.1.0/29 [90/41024000] via 192.168.100.2, 00:00:47, Serial0/0 D 192.168.0.0/19 [90/41152000] via 192.168.100.2, 00:06:06, Serial0/0 R1# ! R2#show ip route eigrp 172.16.0.0/30 is subnetted, 1 subnets D 172.16.1.0 [90/40640000] via 10.1.1.3, 00:03:03, Serial0/1 172.31.0.0/30 is subnetted, 1 subnets D 172.31.1.0 [90/40640000] via 192.168.100.1, 00:04:20, Serial0/0 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks D 10.1.3.0/30 [90/40640000] via 10.1.1.3, 00:08:54, Serial0/1 D 192.168.12.0/23 [90/40640000] via 10.1.1.3, 00:00:20, Serial0/1 D 192.168.8.0/23 [90/40640000] via 10.1.1.3, 00:00:21, Serial0/1 D 192.168.24.0/23 [90/40640000] via 10.1.1.3, 00:00:21, Serial0/1 D 192.168.4.0/23 [90/40640000] via 10.1.1.3, 00:00:21, Serial0/1 D 192.168.20.0/23 [90/40640000] via 10.1.1.3, 00:00:21, Serial0/1 D 192.168.0.0/23 [90/40640000] via 10.1.1.3, 00:00:21, Serial0/1 D 192.168.16.0/23 [90/40640000] via 10.1.1.3, 00:00:21, Serial0/1 R2# ! R3#show ip route eigrp 172.31.0.0/30 is subnetted, 1 subnets D 172.31.1.0 [90/41152000] via 10.1.1.2, 00:04:48, Serial0/1 192.168.200.0/30 is subnetted, 7 subnets D 192.168.200.0 [90/40640000] via 10.1.1.2, 00:04:12, Serial0/1 D 192.168.200.4 [90/40640000] via 10.1.1.2, 00:04:12, Serial0/1 D 192.168.200.8 [90/40640000] via 10.1.1.2, 00:04:12, Serial0/1 D 192.168.200.12 [90/40640000] via 10.1.1.2, 00:04:12, Serial0/1 D 192.168.200.16 [90/40640000] via 10.1.1.2, 00:04:12, Serial0/1 D 192.168.200.20 [90/40640000] via 10.1.1.2, 00:04:12, Serial0/1 D 192.168.200.24 [90/40640000] via 10.1.1.2, 00:04:12, Serial0/1 192.168.100.0/29 is subnetted, 1 subnets D 192.168.100.0 [90/41024000] via 10.1.1.2, 00:04:12, Serial0/1 R3#
    - How do you expect the output of this command to change if you implement summarization? You can also look at the size of each router’s routing table with the show ip route summary command
    R1#show ip route summary IP routing table name is Default-IP-Routing-Table(0) IP routing table maximum-paths is 16 Route Source Networks Subnets Overhead Memory (bytes) connected 0 2 144 272 static 0 0 0 0 eigrp 100 7 10 1224 2312 internal 5 5780 Total 12 12 1368 8364 R1# ! R2#show ip route summary IP routing table name is Default-IP-Routing-Table(0) IP routing table maximum-paths is 16 Route Source Networks Subnets Overhead Memory (bytes) connected 0 9 648 1224 static 0 0 0 0 eigrp 100 7 3 720 1360 internal 5 5780 Total 12 12 1368 8364 R2# ! R3#show ip route summary IP routing table name is Default-IP-Routing-Table(0) IP routing table maximum-paths is 16 Route Source Networks Subnets Overhead Memory (bytes) connected 7 3 720 1360 static 0 0 0 0 eigrp 100 0 9 648 1224 internal 5 5780 Total 12 12 1368 8364 R3#
    Step 3: EIGRP Auto-summarization EIGRP auto-summarization is turned on by default, however it was turned off because thi snetwork had discontiguous networks that was later removed. It is now safe to begin using auto-summarization again. Verify that EIGRP AS 100 is not using auto-summarization on R1 with the show ip protocols command.
    R1#show ip protocols Routing Protocol is "eigrp 100" Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Default networks flagged in outgoing updates Default networks accepted from incoming updates EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0 EIGRP maximum hopcount 100 EIGRP maximum metric variance 1 Redistributing: eigrp 100 EIGRP NSF-aware route hold timer is 240s Automatic network summarization is not in effect Maximum path: 4 Routing for Networks: 172.31.0.0 192.168.100.0 Routing Information Sources: Gateway Distance Last Update (this router) 90 00:18:50 192.168.100.2 90 00:10:19 Distance: internal 90 external 170 R1#
    On R3, execute the auto-summary command in EIGRP R1#conf t R1(config)#router eigrp 100 R1(config-router)#auto-summary R1(config-router)# ! R2#conf t R2(config)#router eigrp 100 R2(config-router)#auto-summary R2(config-router)# ! R3#conf t R3(config)#router eigrp 100 R3(config-router)#auto-summary R3(config-router)# Verify that the summaries are shown by issuing the show ip eigrp topology command on each router.
    R1#show ip eigrp topology IP-EIGRP Topology Table for AS(100)/ID(172.31.1.1) Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 10.0.0.0/8, 1 successors, FD is 41024000 via 192.168.100.2 (41024000/40512000), Serial0/0 P 192.168.100.0/24, 1 successors, FD is 40512000 via Summary (40512000/0), Null0 P 192.168.100.0/29, 1 successors, FD is 40512000 via Connected, Serial0/0 P 192.168.8.0/23, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 P 192.168.12.0/23, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 P 192.168.0.0/23, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 P 192.168.4.0/23, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 P 192.168.24.0/23, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 P 192.168.16.0/23, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 192.168.20.0/23, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 P 192.168.200.0/24, 1 successors, FD is 40640000 via 192.168.100.2 (40640000/128256), Serial0/0 P 172.31.1.0/30, 1 successors, FD is 128256 via Connected, Loopback0 P 172.31.0.0/16, 1 successors, FD is 128256 via Summary (128256/0), Null0 P 172.16.0.0/16, 1 successors, FD is 41152000 via 192.168.100.2 (41152000/40640000), Serial0/0 R1# ! R2#show ip eigrp topology IP-EIGRP Topology Table for AS(100)/ID(192.168.200.25) Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 10.1.3.0/30, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 P 10.0.0.0/8, 1 successors, FD is 40512000 via Summary (40512000/0), Null0 P 10.1.1.0/29, 1 successors, FD is 40512000 via Connected, Serial0/1 P 192.168.100.0/24, 1 successors, FD is 40512000 via Summary (40512000/0), Null0 P 192.168.100.0/29, 1 successors, FD is 40512000 via Connected, Serial0/0 P 192.168.8.0/23, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 P 192.168.12.0/23, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 P 192.168.0.0/23, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 P 192.168.4.0/23, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 192.168.24.0/23, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 P 192.168.16.0/23, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 P 192.168.20.0/23, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 P 192.168.200.0/24, 1 successors, FD is 128256 via Summary (128256/0), Null0 P 192.168.200.0/30, 1 successors, FD is 128256 via Connected, Loopback1 P 192.168.200.4/30, 1 successors, FD is 128256 via Connected, Loopback5 P 192.168.200.8/30, 1 successors, FD is 128256 via Connected, Loopback9 P 192.168.200.12/30, 1 successors, FD is 128256 via Connected, Loopback13 P 192.168.200.16/30, 1 successors, FD is 128256 via Connected, Loopback17 P 172.31.0.0/16, 1 successors, FD is 40640000 via 192.168.100.1 (40640000/128256), Serial0/0 P 192.168.200.20/30, 1 successors, FD is 128256 via Connected, Loopback21 P 192.168.200.24/30, 1 successors, FD is 128256 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status via Connected, Loopback25 P 172.16.0.0/16, 1 successors, FD is 40640000 via 10.1.1.3 (40640000/128256), Serial0/1 R2# ! R3#show ip eigrp topology IP-EIGRP Topology Table for AS(100)/ID(192.168.25.25) Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 10.1.3.0/30, 1 successors, FD is 128256 via Connected, Loopback100 P 10.0.0.0/8, 1 successors, FD is 128256 via Summary (128256/0), Null0 P 10.1.1.0/29, 1 successors, FD is 40512000 via Connected, Serial0/1 P 192.168.100.0/24, 1 successors, FD is 41024000 via 10.1.1.2 (41024000/40512000), Serial0/1 P 192.168.8.0/23, 1 successors, FD is 128256 via Connected, Loopback9 P 192.168.12.0/23, 1 successors, FD is 128256 via Connected, Loopback13 P 192.168.0.0/23, 1 successors, FD is 128256 via Connected, Loopback1 P 192.168.4.0/23, 1 successors, FD is 128256 via Connected, Loopback5 P 192.168.24.0/23, 1 successors, FD is 128256 via Connected, Loopback25 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 192.168.16.0/23, 1 successors, FD is 128256 via Connected, Loopback17 P 192.168.20.0/23, 1 successors, FD is 128256 via Connected, Loopback21 P 192.168.200.0/24, 1 successors, FD is 40640000 via 10.1.1.2 (40640000/128256), Serial0/1 P 172.31.0.0/16, 1 successors, FD is 41152000 via 10.1.1.2 (41152000/40640000), Serial0/1 P 172.16.0.0/16, 1 successors, FD is 128256 via Summary (128256/0), Null0 P 172.16.1.0/30, 1 successors, FD is 128256 via Connected, Loopback172 R3#
    Step 4: EIGRP Manual Summarization Implement the summarization on R3 as follows R3#conf t R3(config)#interface serial 0/1 R3(config-if)#ip summary-address eigrp 100 192.168.0.0 255.255.224.0 5 R3(config-if)# The 100 parameter instructs this to be sent out only to neighbors in EIGRP AS 100.
    R1#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is 0.0.0.0 to network 172.31.0.0 172.16.0.0/16 is subnetted, 1 subnets D 172.16.0.0 [90/41152000] via 192.168.100.2, 00:21:51, Serial0/0 * 172.31.0.0/16 is variably subnetted, 2 subnets, 2 masks C 172.31.1.0/30 is directly connected, Loopback0 D* 172.31.0.0/16 is a summary, 00:23:11, Null0 D 192.168.200.0/24 [90/40640000] via 192.168.100.2, 00:22:25, Serial0/0 D 10.0.0.0/8 [90/41024000] via 192.168.100.2, 00:22:25, Serial0/0 192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.100.0/29 is directly connected, Serial0/0 D 192.168.100.0/24 is a summary, 00:23:17, Null0 D 192.168.0.0/19 [90/41152000] via 192.168.100.2, 00:06:26, Serial0/0 R1# ! R2#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is 192.168.100.1 to network 172.31.0.0 D 172.16.0.0/16 [90/40640000] via 10.1.1.3, 00:25:52, Serial0/1 D* 172.31.0.0/16 [90/40640000] via 192.168.100.1, 00:26:27, Serial0/0 192.168.200.0/24 is variably subnetted, 8 subnets, 2 masks C 192.168.200.0/30 is directly connected, Loopback1 D 192.168.200.0/24 is a summary, 00:26:27, Null0 C 192.168.200.4/30 is directly connected, Loopback5 C 192.168.200.8/30 is directly connected, Loopback9 C 192.168.200.12/30 is directly connected, Loopback13 C 192.168.200.16/30 is directly connected, Loopback17 C 192.168.200.20/30 is directly connected, Loopback21 C 192.168.200.24/30 is directly connected, Loopback25 10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks D 10.1.3.0/30 [90/40640000] via 10.1.1.3, 01:00:35, Serial0/1 C 10.1.1.0/29 is directly connected, Serial0/1 D 10.0.0.0/8 is a summary, 00:26:29, Null0 192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.100.0/29 is directly connected, Serial0/0 D 192.168.100.0/24 is a summary, 00:26:29, Null0 D 192.168.0.0/19 [90/40640000] via 10.1.1.3, 00:10:32, Serial0/1 R2# ! R3#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is 10.1.1.2 to network 172.31.0.0 172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks D 172.16.0.0/16 is a summary, 00:28:22, Null0 C 172.16.1.0/30 is directly connected, Loopback172 D* 172.31.0.0/16 [90/41152000] via 10.1.1.2, 00:28:22, Serial0/1 D 192.168.200.0/24 [90/40640000] via 10.1.1.2, 00:29:07, Serial0/1 10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks C 10.1.3.0/30 is directly connected, Loopback100 C 10.1.1.0/29 is directly connected, Serial0/1 D 10.0.0.0/8 is a summary, 00:28:24, Null0 D 192.168.100.0/24 [90/41024000] via 10.1.1.2, 00:29:08, Serial0/1 C 192.168.12.0/23 is directly connected, Loopback13 C 192.168.8.0/23 is directly connected, Loopback9 C 192.168.24.0/23 is directly connected, Loopback25 C 192.168.4.0/23 is directly connected, Loopback5 C 192.168.20.0/23 is directly connected, Loopback21 C 192.168.0.0/23 is directly connected, Loopback1 D 192.168.0.0/19 is a summary, 00:12:56, Null0 C 192.168.16.0/23 is directly connected, Loopback17 R3#
    - At this point, you have efficiently summarized the network. Based on your knowledge of routing protocols and techniques, are there any other ways to minimize the routing table even further for this topology without filtering routes? Step 5: Default Network Advertisement The default network you will configure is 172.31.0.0/16, because this is the path to the Internet. - The ip default-network command that you will configure on R1 propagates through the EIGRP system so that each router sees its candidate default network as the path with shortest feasible distance to the default network (172.31.0.0/16). Issue this command on R1. R1#conf t R1(config)#ip default-network 172.31.0.0 R1(config)#
    R2#show ip eigrp topology 172.31.0.0/16 IP-EIGRP (AS 100): Topology entry for 172.31.0.0/16 State is Passive, Query origin flag is 1, 1 Successor(s), FD is 40640000 Routing Descriptor Blocks: 192.168.100.1 (Serial0/0), from 192.168.100.1, Send flag is 0x0 Composite metric is (40640000/128256), Route is Internal Vector metric: Minimum bandwidth is 64 Kbit Total delay is 25000 microseconds Reliability is 255/255 Load is 1/255 Minimum MTU is 1500 Hop count is 1 Exterior flag is set R2#
    How has the routing table changed on each of your routers? Use the command show ip route
    R1#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is 0.0.0.0 to network 172.31.0.0 172.16.0.0/16 is subnetted, 1 subnets D 172.16.0.0 [90/41152000] via 192.168.100.2, 00:54:09, Serial0/0 * 172.31.0.0/16 is variably subnetted, 2 subnets, 2 masks C 172.31.1.0/30 is directly connected, Loopback0 D* 172.31.0.0/16 is a summary, 00:55:29, Null0 D 192.168.200.0/24 [90/40640000] via 192.168.100.2, 00:54:43, Serial0/0 D 10.0.0.0/8 [90/41024000] via 192.168.100.2, 00:54:43, Serial0/0 192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.100.0/29 is directly connected, Serial0/0 D 192.168.100.0/24 is a summary, 00:55:37, Null0 D 192.168.0.0/19 [90/41152000] via 192.168.100.2, 00:38:45, Serial0/0 R1# ! R2#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is 192.168.100.1 to network 172.31.0.0 D 172.16.0.0/16 [90/40640000] via 10.1.1.3, 00:56:34, Serial0/1 D* 172.31.0.0/16 [90/40640000] via 192.168.100.1, 00:57:08, Serial0/0 192.168.200.0/24 is variably subnetted, 8 subnets, 2 masks C 192.168.200.0/30 is directly connected, Loopback1 D 192.168.200.0/24 is a summary, 00:57:08, Null0 C 192.168.200.4/30 is directly connected, Loopback5 C 192.168.200.8/30 is directly connected, Loopback9 C 192.168.200.12/30 is directly connected, Loopback13 C 192.168.200.16/30 is directly connected, Loopback17 C 192.168.200.20/30 is directly connected, Loopback21 C 192.168.200.24/30 is directly connected, Loopback25 10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks D 10.1.3.0/30 [90/40640000] via 10.1.1.3, 01:31:17, Serial0/1 C 10.1.1.0/29 is directly connected, Serial0/1 D 10.0.0.0/8 is a summary, 00:57:12, Null0 192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.100.0/29 is directly connected, Serial0/0 D 192.168.100.0/24 is a summary, 00:57:12, Null0 D 192.168.0.0/19 [90/40640000] via 10.1.1.3, 00:41:15, Serial0/1 R2# ! R3#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is 10.1.1.2 to network 172.31.0.0 172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks D 172.16.0.0/16 is a summary, 00:58:27, Null0 C 172.16.1.0/30 is directly connected, Loopback172 D* 172.31.0.0/16 [90/41152000] via 10.1.1.2, 00:58:27, Serial0/1 D 192.168.200.0/24 [90/40640000] via 10.1.1.2, 00:59:12, Serial0/1 10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks C 10.1.3.0/30 is directly connected, Loopback100 C 10.1.1.0/29 is directly connected, Serial0/1 D 10.0.0.0/8 is a summary, 00:58:31, Null0 D 192.168.100.0/24 [90/41024000] via 10.1.1.2, 00:59:16, Serial0/1 C 192.168.12.0/23 is directly connected, Loopback13 C 192.168.8.0/23 is directly connected, Loopback9 C 192.168.24.0/23 is directly connected, Loopback25 C 192.168.4.0/23 is directly connected, Loopback5 C 192.168.20.0/23 is directly connected, Loopback21 C 192.168.0.0/23 is directly connected, Loopback1 D 192.168.0.0/19 is a summary, 00:43:04, Null0 C 192.168.16.0/23 is directly connected, Loopback17 R3#
    Conclusion Issue the show ip protocols command again. How has the output changed?
    R1#show ip protocols Routing Protocol is "eigrp 100" Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Default networks flagged in outgoing updates Default networks accepted from incoming updates EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0 EIGRP maximum hopcount 100 EIGRP maximum metric variance 1 Redistributing: eigrp 100 EIGRP NSF-aware route hold timer is 240s Automatic network summarization is in effect Automatic address summarization: 192.168.100.0/24 for Loopback0 Summarizing with metric 40512000 172.31.0.0/16 for Serial0/0 Summarizing with metric 128256 Maximum path: 4 Routing for Networks: 172.31.0.0 192.168.100.0 Routing Information Sources: Gateway Distance Last Update (this router) 90 01:02:31 Gateway Distance Last Update 192.168.100.2 90 00:45:41 Distance: internal 90 external 170 R1#
    - By what amount has the total routing table size decreased on each router?
    R1#show ip route summary IP routing table name is Default-IP-Routing-Table(0) IP routing table maximum-paths is 16 Route Source Networks Subnets Overhead Memory (bytes) connected 0 2 144 272 static 0 0 0 0 eigrp 100 3 3 432 3876 internal 3 3468 Total 6 5 576 7616 R1# ! R2#show ip route summary IP routing table name is Default-IP-Routing-Table(0) IP routing table maximum-paths is 16 Route Source Networks Subnets Overhead Memory (bytes) connected 0 9 648 1224 static 0 0 0 0 eigrp 100 3 4 504 2992 internal 3 3468 Total 6 13 1152 7684 R2# ! R3#show ip route summary IP routing table name is Default-IP-Routing-Table(0) IP routing table maximum-paths is 16 Route Source Networks Subnets Overhead Memory (bytes) connected 7 3 720 1360 static 0 0 0 0 eigrp 100 4 2 432 2856 internal 2 2312 Total 13 5 1152 6528 R3#